Back to overview
Maintenance

Issue with Neoprotect and Xentra

Oct 02 at 07:15pm EDT  –  Oct 02 at 08:25pm EDT
Affected services
panel.phyntra.net
billing.phyntra.net

Resolved
Oct 02 at 07:15pm EDT

Due to a issue with Neoprotect and Xentra, our services where down for a hour and 10 minutes.